centos rabbitmq 3.1.5 安装及配置 详细指南

centos rabbitmq 3.2.1 安装及配置 详细指南

详细的过程就看这里了,我不知道为什么,但是据我的实践表明3.2.1在centos上安装后用3.2.1的javaclient是不能链接,可能是我没安装好什么东西吧。

需要注意的一些事项:

python要升级到2.5以上。

安装依赖

sudo yum install -y erlang xmlto python-simplejson

升级python 到 2.6

Centos升级python到2.6

sudo mkdir /var/log/rabbitmq
sudo mkdir /var/lib/rabbitmq
sudo chown -R user:user /var/log/rabbitmq
sudo chown -R user:user /var/lib/rabbitmq

下载安装rabbitmq

wget http://www.rabbitmq.com/releases/rabbitmq-server/v3.1.5/rabbitmq-server-3.1.5.tar.gz

tar xzf rabbitmq-server-3.1.5.tar.gz

cd rabbitmq-server-3.1.5

make TARGET_DIR=/home/user/rabbitmq3/bin SBIN_DIR=/home/user/rabbitmq3/sbin MAN_DIR=/home/user/rabbitmq3/man DOC_INSTALL_DIR=/home/user/rabbitmq3/doc install

cd ~/rabbitmq3/bin/sbin

./rabbitmq-server

如果看到如下所示的提示就表明安装成功。
RabbitMQ 3.1.5. Copyright (C) 2007-2013 GoPivotal, Inc.
## ## Licensed under the MPL. See http://www.rabbitmq.com/
## ##
########## Logs: /var/log/rabbitmq/rabbit@dev-tts-mq.log
###### ## /var/log/rabbitmq/rabbit@dev-tts-mq-sasl.log
##########
Starting broker… completed with 0 plugins.

发表评论

电子邮件地址不会被公开。 必填项已用 * 标注

您可以使用这些 HTML 标签和属性: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>